Remove build-dep on autotools-dev which has been subsumed by DH 10.
[libmpdclient-debian.git] / debian / changelog
1 libmpdclient (2.11-1) UNRELEASED; urgency=medium
2
3   * New upstream version.
4   * Update standards version to 4.1.1:
5     - Update to debhelper compat version 10.
6     - Remove build-dep on autotools-dev which has been subsumed by DH 10.
7     - Use priority "optional" in place of deprecated "extra".
8
9  -- Sebastian Harl <tokkee@debian.org>  Sun, 22 Oct 2017 13:10:25 +0200
10
11 libmpdclient (2.9-1) unstable; urgency=low
12
13   * New upstream release (Closes: #671094).
14   * debian/libmpdclient-dev.install:
15     - Install the vapi file.
16   * debian/libmpdclient2.symbols:
17     - Updated for new upstream version.
18   * debian/rules:
19     - Split build target into build-arch and build-indep.
20     - Use dpkg-buildflags to get CPPFLAGS and CFLAGS.
21     - Use dh_autotools-dev* to update config.{sub,guess}; thanks to Matthias
22       Klose for reporting and suggesting this (Closes: #727416).
23   * debian/control:
24     - Updated standards-version to 3.9.4.
25
26  -- Sebastian Harl <tokkee@debian.org>  Sat, 23 Nov 2013 19:53:49 +0100
27
28 libmpdclient (2.3-1) unstable; urgency=low
29
30   * New upstream release.
31     - Do not try to install GIF files from doc/api/html/ if none are available
32       (doxygen no longer creates any GIF files since version 1.7 or so)
33       (Closes: #590397).
34   * debian/control:
35     - Updated standards-version to 3.9.1 -- no changes.
36   * debian/libmpdclient2.symbols:
37     - Updated for 2.3.
38
39  -- Sebastian Harl <tokkee@debian.org>  Thu, 29 Jul 2010 20:39:38 +0200
40
41 libmpdclient (2.2-1) unstable; urgency=low
42
43   * New upstream release.
44   * debian/libmpdclient2.symbols:
45     - Updated for 2.2.
46   * debian/control:
47     - Updated to standards-version 3.8.4 -- no changes.
48     - Let all packages depend on ${misc:Depends}, as suggested by debhelper.
49   * debian/rules:
50     - Let dh_makeshlibs create a dependency on libmpdclient2 >= 2.2, which is
51       required since new functionality has been added.
52
53  -- Sebastian Harl <tokkee@debian.org>  Wed, 09 Jun 2010 18:44:12 +0200
54
55 libmpdclient (2.1-1) unstable; urgency=low
56
57   * New upstream release.
58   * debian/libmpdclient2.symbols:
59     - Updated for 2.1.
60   * debian/rules:
61     - Run 'make check' unless the nocheck option has been specified in
62       DEB_BUILD_OPTIONS.
63
64  -- Sebastian Harl <tokkee@debian.org>  Sun, 27 Dec 2009 00:09:08 +0100
65
66 libmpdclient (2.0-1) unstable; urgency=low
67
68   * Initial release (Closes: #549646).
69
70  -- Sebastian Harl <tokkee@debian.org>  Thu, 22 Oct 2009 00:51:34 +0200
71