Override embedded-javascript-library lintian warning.
[libmpdclient-debian.git] / debian / changelog
1 libmpdclient (2.11-1) UNRELEASED; urgency=medium
2
3   * New upstream version.
4   * Update standards version to 4.1.1:
5     - Update to debhelper compat version 10.
6     - Remove build-dep on autotools-dev which has been subsumed by DH 10.
7     - Use priority "optional" in place of deprecated "extra".
8     - Override embedded-javascript-library lintian warning: doc embeds
9       jquery.js which is a modified version from Doxygen.
10
11  -- Sebastian Harl <tokkee@debian.org>  Sun, 22 Oct 2017 13:10:25 +0200
12
13 libmpdclient (2.9-1) unstable; urgency=low
14
15   * New upstream release (Closes: #671094).
16   * debian/libmpdclient-dev.install:
17     - Install the vapi file.
18   * debian/libmpdclient2.symbols:
19     - Updated for new upstream version.
20   * debian/rules:
21     - Split build target into build-arch and build-indep.
22     - Use dpkg-buildflags to get CPPFLAGS and CFLAGS.
23     - Use dh_autotools-dev* to update config.{sub,guess}; thanks to Matthias
24       Klose for reporting and suggesting this (Closes: #727416).
25   * debian/control:
26     - Updated standards-version to 3.9.4.
27
28  -- Sebastian Harl <tokkee@debian.org>  Sat, 23 Nov 2013 19:53:49 +0100
29
30 libmpdclient (2.3-1) unstable; urgency=low
31
32   * New upstream release.
33     - Do not try to install GIF files from doc/api/html/ if none are available
34       (doxygen no longer creates any GIF files since version 1.7 or so)
35       (Closes: #590397).
36   * debian/control:
37     - Updated standards-version to 3.9.1 -- no changes.
38   * debian/libmpdclient2.symbols:
39     - Updated for 2.3.
40
41  -- Sebastian Harl <tokkee@debian.org>  Thu, 29 Jul 2010 20:39:38 +0200
42
43 libmpdclient (2.2-1) unstable; urgency=low
44
45   * New upstream release.
46   * debian/libmpdclient2.symbols:
47     - Updated for 2.2.
48   * debian/control:
49     - Updated to standards-version 3.8.4 -- no changes.
50     - Let all packages depend on ${misc:Depends}, as suggested by debhelper.
51   * debian/rules:
52     - Let dh_makeshlibs create a dependency on libmpdclient2 >= 2.2, which is
53       required since new functionality has been added.
54
55  -- Sebastian Harl <tokkee@debian.org>  Wed, 09 Jun 2010 18:44:12 +0200
56
57 libmpdclient (2.1-1) unstable; urgency=low
58
59   * New upstream release.
60   * debian/libmpdclient2.symbols:
61     - Updated for 2.1.
62   * debian/rules:
63     - Run 'make check' unless the nocheck option has been specified in
64       DEB_BUILD_OPTIONS.
65
66  -- Sebastian Harl <tokkee@debian.org>  Sun, 27 Dec 2009 00:09:08 +0100
67
68 libmpdclient (2.0-1) unstable; urgency=low
69
70   * Initial release (Closes: #549646).
71
72  -- Sebastian Harl <tokkee@debian.org>  Thu, 22 Oct 2009 00:51:34 +0200
73