11b5dd030ebc497bcfb5bd6be5f5cf4caa83ffa6
[libmpdclient-debian.git] / debian / changelog
1 libmpdclient (2.16-1) UNRELEASED; urgency=medium
2
3   [ Helmut Grohne ]
4   * Pass a multiarch --libdir to ./configure (Closes: #871412).
5
6   [ Sebastian Harl ]
7   * New upstream version.
8   * Update standards version to 4.1.1:
9     - Update to debhelper compat version 10.
10     - Remove build-dep on autotools-dev which has been subsumed by DH 10.
11     - Use priority "optional" in place of deprecated "extra".
12     - Override embedded-javascript-library lintian warning: doc embeds
13       jquery.js which is a modified version from Doxygen.
14
15   [ Geoffroy Youri Berret ]
16   * New upstream version (Closes: #900513).
17   * Update standards version to 4.2.1:
18     - Update debhelper to compat 11.
19   * Update upstream Homepage.
20   * update d/watch and enable pgpmode.
21
22  -- Geoffroy Youri Berret <efrim@azylum.org>  Sun, 02 Dec 2018 18:54:05 +0100
23
24 libmpdclient (2.9-1) unstable; urgency=low
25
26   * New upstream release (Closes: #671094).
27   * debian/libmpdclient-dev.install:
28     - Install the vapi file.
29   * debian/libmpdclient2.symbols:
30     - Updated for new upstream version.
31   * debian/rules:
32     - Split build target into build-arch and build-indep.
33     - Use dpkg-buildflags to get CPPFLAGS and CFLAGS.
34     - Use dh_autotools-dev* to update config.{sub,guess}; thanks to Matthias
35       Klose for reporting and suggesting this (Closes: #727416).
36   * debian/control:
37     - Updated standards-version to 3.9.4.
38
39  -- Sebastian Harl <tokkee@debian.org>  Sat, 23 Nov 2013 19:53:49 +0100
40
41 libmpdclient (2.3-1) unstable; urgency=low
42
43   * New upstream release.
44     - Do not try to install GIF files from doc/api/html/ if none are available
45       (doxygen no longer creates any GIF files since version 1.7 or so)
46       (Closes: #590397).
47   * debian/control:
48     - Updated standards-version to 3.9.1 -- no changes.
49   * debian/libmpdclient2.symbols:
50     - Updated for 2.3.
51
52  -- Sebastian Harl <tokkee@debian.org>  Thu, 29 Jul 2010 20:39:38 +0200
53
54 libmpdclient (2.2-1) unstable; urgency=low
55
56   * New upstream release.
57   * debian/libmpdclient2.symbols:
58     - Updated for 2.2.
59   * debian/control:
60     - Updated to standards-version 3.8.4 -- no changes.
61     - Let all packages depend on ${misc:Depends}, as suggested by debhelper.
62   * debian/rules:
63     - Let dh_makeshlibs create a dependency on libmpdclient2 >= 2.2, which is
64       required since new functionality has been added.
65
66  -- Sebastian Harl <tokkee@debian.org>  Wed, 09 Jun 2010 18:44:12 +0200
67
68 libmpdclient (2.1-1) unstable; urgency=low
69
70   * New upstream release.
71   * debian/libmpdclient2.symbols:
72     - Updated for 2.1.
73   * debian/rules:
74     - Run 'make check' unless the nocheck option has been specified in
75       DEB_BUILD_OPTIONS.
76
77  -- Sebastian Harl <tokkee@debian.org>  Sun, 27 Dec 2009 00:09:08 +0100
78
79 libmpdclient (2.0-1) unstable; urgency=low
80
81   * Initial release (Closes: #549646).
82
83  -- Sebastian Harl <tokkee@debian.org>  Thu, 22 Oct 2009 00:51:34 +0200