Pass a multiarch --libdir to ./configure.
[libmpdclient-debian.git] / debian / changelog
1 libmpdclient (2.11-1) UNRELEASED; urgency=medium
2
3   [ Helmut Grohne ]
4   * Pass a multiarch --libdir to ./configure (Closes: #871412).
5
6   [ Sebastian Harl ]
7   * New upstream version.
8   * Update standards version to 4.1.1:
9     - Update to debhelper compat version 10.
10     - Remove build-dep on autotools-dev which has been subsumed by DH 10.
11     - Use priority "optional" in place of deprecated "extra".
12     - Override embedded-javascript-library lintian warning: doc embeds
13       jquery.js which is a modified version from Doxygen.
14
15  -- Sebastian Harl <tokkee@debian.org>  Sun, 22 Oct 2017 13:10:25 +0200
16
17 libmpdclient (2.9-1) unstable; urgency=low
18
19   * New upstream release (Closes: #671094).
20   * debian/libmpdclient-dev.install:
21     - Install the vapi file.
22   * debian/libmpdclient2.symbols:
23     - Updated for new upstream version.
24   * debian/rules:
25     - Split build target into build-arch and build-indep.
26     - Use dpkg-buildflags to get CPPFLAGS and CFLAGS.
27     - Use dh_autotools-dev* to update config.{sub,guess}; thanks to Matthias
28       Klose for reporting and suggesting this (Closes: #727416).
29   * debian/control:
30     - Updated standards-version to 3.9.4.
31
32  -- Sebastian Harl <tokkee@debian.org>  Sat, 23 Nov 2013 19:53:49 +0100
33
34 libmpdclient (2.3-1) unstable; urgency=low
35
36   * New upstream release.
37     - Do not try to install GIF files from doc/api/html/ if none are available
38       (doxygen no longer creates any GIF files since version 1.7 or so)
39       (Closes: #590397).
40   * debian/control:
41     - Updated standards-version to 3.9.1 -- no changes.
42   * debian/libmpdclient2.symbols:
43     - Updated for 2.3.
44
45  -- Sebastian Harl <tokkee@debian.org>  Thu, 29 Jul 2010 20:39:38 +0200
46
47 libmpdclient (2.2-1) unstable; urgency=low
48
49   * New upstream release.
50   * debian/libmpdclient2.symbols:
51     - Updated for 2.2.
52   * debian/control:
53     - Updated to standards-version 3.8.4 -- no changes.
54     - Let all packages depend on ${misc:Depends}, as suggested by debhelper.
55   * debian/rules:
56     - Let dh_makeshlibs create a dependency on libmpdclient2 >= 2.2, which is
57       required since new functionality has been added.
58
59  -- Sebastian Harl <tokkee@debian.org>  Wed, 09 Jun 2010 18:44:12 +0200
60
61 libmpdclient (2.1-1) unstable; urgency=low
62
63   * New upstream release.
64   * debian/libmpdclient2.symbols:
65     - Updated for 2.1.
66   * debian/rules:
67     - Run 'make check' unless the nocheck option has been specified in
68       DEB_BUILD_OPTIONS.
69
70  -- Sebastian Harl <tokkee@debian.org>  Sun, 27 Dec 2009 00:09:08 +0100
71
72 libmpdclient (2.0-1) unstable; urgency=low
73
74   * Initial release (Closes: #549646).
75
76  -- Sebastian Harl <tokkee@debian.org>  Thu, 22 Oct 2009 00:51:34 +0200
77